OEA 10.2B06: Project->Properties->OE->Build: Static

Posted by Stefan Marquardt on 19-Feb-2013 01:08


yesterday i tried to look what happens if a define static file destination".

I created a new folder within the browse the menu and selected this new one.

The result:

- disk got neary full

- in the definded folder static is a subfolder named static and in this subfolder a subfolder static and so on ...

- in this subfolders are copies of some other folders and files which are original on the root of the first static folder

- i can't delete this subfolder "invasion" -> "source filename to long for filesystem"

- if i click a long time through this static subfoders this lowest accessable folder hasn't a full context menu (delete, copy and so on is missing)

- i can't open a prompt in the folder one above the last accesable static folder (filename or extension too long)

It looks like this:


Any idea how to remove this folders from my disk?


All Replies

Posted by Anil Kumar on 19-Feb-2013 03:11

Hi Stefan,

There is an OpenEdge Architect issue (OE00196574 - Nested folders created on project refresh after changing StaticFileDest) because of which nested folders gets created under the provided 'Static File Destination' directory. The problem which you are facing is Windows bug and Windows file system will not allow us to delete specific file or the directory if it exceeds maximum limit in the path.

Following are the set of workarounds which might be helpful for you to resolve the problem.

1) If the specific 'Static File Destination' directory points to one of the folders inside project, try deleting the folder directly from the Project Explorer in OpenEdge Architect (Attached snapshot).

2) Make/Map a drive mapping about halfway into the folder structure  and delete the latter half of the file heirarcy using mapped drive path.

For example if you are getting the error trying to delete:


Then map a network drive T: to


This will reduce the file herarch down to a smaller path. Open  explorer and view the T: drive. You should now be able to delete subfolders without an  issue, thereby deleting half the folder hierarchy. After that,  disconnect the T: drive and try to delete whatever is left normally.   Problem solved!

Googling might provide few more simpler solutions.

Hope this helps.

Thanks and Regards,

Anil Kumar.

Posted by Stefan Marquardt on 19-Feb-2013 05:45

Vanessa from EMEA support gave me this script:

if EXIST "D:/Cash/phc26c/static" (
REN "D:/Cash/phc26c/static" "tempstatic"
MOVE "D:/Cash/phc26c/tempstatic/static" "D:/Cash/phc26c"
RMDIR /S /Q "D:/Cash/phc26c/tempstatic"
GOTO LoopStart
) else (
    ECHO "script finished"


This was the shortest version, deleting within OEA wasn't possible.

BTW: The nested directories isn't a bug from windows, isn't it?

The bug is that delete isn't possible on an easy way but who creates such a cray nested directory by hand?


Posted by Stefan Marquardt on 20-Feb-2013 03:37

Hi Anil,

the script only moved the subfolder structure to another folder.

Meanwhile i have this beginning from d:\ d:\static\static\static\....

Deleting from Eclipse doesn't works!

Comment: What a nasty function in a IDE that creates folders but isn't able to delete.

Created a share at the lowest reachable


and created a share "static":

Tried to delete within this share: Not possible, tried to access the lowest reachable folder in this share and delete: Not possible!



Posted by vlopez on 20-Feb-2013 04:01

Hello Stefan,

I tested the script before sending it to you and it worked fine.

It's strange that you ended up with a static directory on D:\ , based on the script version you posted you were not moving anything to D:\ .

Please verify that you are moving the correct folders and removing the correct directory when modifying your script.

Here's the link where I took the example from :



GOTO LoopStart

I added a conditional IF to stop the execution when the last folder is deleted (otherwise it will run forever complaining that the folder couldn't be found).



Posted by Stefan Marquardt on 20-Feb-2013 05:57

Windows stil seems to have trouble with this folder.

I opened a cmd (als admin), select d:\ and type

"ren static ttt"

Access denied

Created a new folder that inherits from D:\ like static, "ren" no problem!

Posted by Anil Kumar on 20-Feb-2013 08:18

Hi Stefan,

Did you try solution which is provided by me regarding map drive one.

(Make/Map a drive mapping about halfway into the folder structure and  delete the latter half of the file heirarcy using mapped drive path).

Are you facing problems even after performing/following this?

Thanks and Regards,

Anil Kumar.

Posted by Stefan Marquardt on 21-Feb-2013 01:23


i think i did (post from 20.02.2013 04:37).

Today - after reboot - ths script solution that Vanessa found via google worked. It seems to be that something was blocking the folder.

If OE IDE creates such a "time wasting problem", it would be nice to get a KB for it, especially for a known bug.

Or better a "Fixit" like MS does.


Posted by vlopez on 21-Feb-2013 03:31

Hi Stefan,

A knowledge base article has been created for this problem. I also included the batch script to delete the recurring folders.

I will leave the link here for anyone else running into the same issue.



This thread is closed