Dev Studio - Mobile App - unable to login

Posted by sam on 13-Apr-2013 02:26


I am trying to test build a Mobile App.I downloaded the evaluation copy of OE 11.2.Completed the set up for OE explorer, Appserver and webserver.
when I try to set up Mobile App through Dev Studio,I am required to enter the login credentials (per OE document it should be the same as Id which I use for accessing progress community site).
However when I enter that login info, I always get below message.

"Connection Failed. Either the OpenEdge Explorer service is not running on machine or the port number is wrong."

Any idea what could be the reason.(using the same login which I am trying, I had earlier downloaded the evaluation copy as well)


All Replies

Posted by mgarimid on 14-Apr-2013 23:20

Hi Sam,

Can you please check your proxy settings in PDSOE preferences --> General--> Network Connections. Please share those detiails with us what are selected.

And can  you please provide PDSOE log file after you reproduced the issue. Log file location was : /.metadata/.log

It  will be helpfull if you set debug level in eclipse.ini file  (eclipse.ini file location is at:  C:\Progress\DeveloperStudio3.7\eclipse\eclipse.ini), open this file and  add -Doeide.logging=4 at end of the file and save.

Now start the PDSOE and reproduce the scenario. Now log file will have all debug traces.

Thanks and Regards

Mogileswara Rao

Posted by sam on 15-Apr-2013 09:38

Thanks Mogileswara.

After seeing  your reply, I went and set up the proxy and enabled debugging. still getting the same error. I've attached the .log file.


Sam V

Posted by egarcia on 15-Apr-2013 09:44


It might also help to know if you get any messages when trying to login to the Mobile App Builder using a web browser:

I hope this helps.

Posted by vvalakon on 16-Apr-2013 00:44

Hi Sam,

Can you change the Active provider Value from "Native" to "Direct" in PDSOE preferences ( General -> Network Connections), And try to test the same scenario after restarting the PDSOE on same workspace.



Posted by sam on 16-Apr-2013 05:10


I changed the value and re-started but I still get the same message.

could this be problem because of it is trying to access secure site (ie



Posted by sam on 16-Apr-2013 05:18

when I used this option, initially the server certificate warning was shown and when I chose 'proceed anyway' (using chrome) I was able to proceed.

But still cant do through Dev Studio.



Posted by sam on 06-Jun-2013 07:44

I was informed by Progress that this issue has been fixed with the latest SP ie OE 11.2.1.

thanks to all who responded to my questions.

This thread is closed