Openedge Explorer - Deleting Webservices Adapter

Posted by rrajan on 20-Aug-2013 13:08

I have create a new webservices adapter in Openedge Explorer in Progress 11.2. I am now trying to delete it but the delete option is not available. Any specific reason why the Delete option is not visible. I have the default wsa instance it has the delete option. Please let me know how to delete the other instance which I have newly created

All Replies

Posted by Anil Kumar on 21-Aug-2013 01:21

Hi Ramalingam,

All the resources which are part of OEM are listed under Resources page.

      Resources -> Open New Resources Tab

Select the newly created Web Service Adapter instance hyperlink. It will redirect to instance page. You can find Delete button in the page through which deletion of specific WSA instance can be done.

Hope this helps.

Thanks and Regards,

Anil Kumar.

Posted by rrajan on 21-Aug-2013 18:47

Hi Anil,

Thanks for the reply. I am not getting the delete button in that screen. But for the built in wsa adapter instance I have the delete option available. I want to delete the wrong one which I have created. Please let me know if there are any other options for deleting the same. Thanks.



Posted by Matt Baker on 21-Aug-2013 21:37

The delete button doesn't usually show up if the service is considered running.  This is because some of the data that gets deleted is important to the service to run properly.

Change the URL or stop the service and refresh the page and the delete button should show up.

Posted by rrajan on 21-Aug-2013 21:55

The configuration option is not available it says as "wsa.rc2 not found it was probably deleted by another user". So now the delete option is not displayed and the status is in disabled. Please let me know if there are any other ways to delete it.



Posted by Matt Baker on 22-Aug-2013 08:05

dots (.) in resource names are a "bad thing".  It is a bug that you were allows to type one in.

You will need to manually remove the instance from the /properties/ file.

This thread is closed