Virtual Print Engine

Posted by Jens Dahlin on 17-Dec-2012 06:40


We've been running an old version (3.60) of IdealSoftwares Virtual Pring Engine for ages and it's worked like a charm.

Now when we are upgrading to 11.1 (from 10.2B05) it's stopped working. No .w's with the Active X added can be run and they cannot be opened in the AppBuilder. It's not possible to add the Active X either - everything results in the same error: OpenEdge Graphical Client stopped working.

Anybody experienced the same?

All Replies

Posted by Admin on 17-Dec-2012 06:44

Maybe another case of this here:

You need to make sure that this Active X Control works with Visual Studio 2010 compiled applications (prowin32.exe in 11.x) and DEP (data execution prevention).

Posted by Jens Dahlin on 17-Dec-2012 06:47

Further testing makes me think this is related to Windows 7 rather than OpenEdge 11...

Posted by jankeir on 17-Dec-2012 06:51

Jens, we're running vpe 3.6 on windows 7 64bit without problems with OE 10.2B. I haven't tried with oe11 yet.

Posted by Admin on 17-Dec-2012 06:53

In that case you should contact the vendor of VPE and ask for their current status related to VS2010 built applications and DEP. Maybe Progress support knows the answer already...

Posted by Admin on 17-Dec-2012 06:59

Which version of Windows did you try? DEP was introduced in Windows XP Service Pack 2.

Posted by Jens Dahlin on 17-Dec-2012 07:02

Works on XP Service Pack 3 but not on Windows 7 Service Pack 1. Both 32 bits.

Posted by Jens Dahlin on 17-Dec-2012 08:38

FYI, it doesn't seem that hard to upgrade from 3.60 to 6.10. So far I've only found one call to VPE that needs to be rewritten, PICTURE(), the method for inserting a picture. Apart from that two methods need to be called when initiating the document to set rendering mode and measurements to be compatible with version 3.60.

This thread is closed