utf-8

Posted by rbf on 30-Jan-2010 03:13

What does it take to create an utf-8 application in OpenEdge GUI for .NET?

All Replies

Posted by Matt Baker on 30-Jan-2010 08:25

You need to set your -cpinternal and -cpstream to UTF-8.  Assuming you are using OEA, then you should set the workspace to save your files as UTF-8 as well so the compiler will read the files generated by OEA in the proper code page.  And make sure whatever build system you are using is setup to use at least -cpstream as utf-8 as well.

OEA Visual Designer writes the .resx files with utf-8 by default always so you don't need to change anything here.

Internally, .NET uses utf-16, but OpenEdge will handle any interactions between the CLR and the AVM appropriately so there is nothing to do here either.

Posted by rbf on 30-Jan-2010 09:48

Ok thanks that is good news and very helpful.

I am almost there but how exactly do you do this:

set the workspace to save your files as UTF-8 as well so the compiler will read the files generated by OEA in the proper code page.  
Posted by Admin on 30-Jan-2010 12:16

I am almost there but how exactly do you do this:

For the whole workspace: Window -> Preferences -> General -> Workspace

On a per project basis:

Project properties -> Resource

It's the text file encoding setting. By the way: This setting also allows code pages not in the list (like ibm850).

Posted by rbf on 17-Feb-2010 15:33

Thnx Mike. Works like a charm.

This thread is closed