Incompatible datatypes... bug, or am I missing something ?

Posted by ge1971 on 23-Mar-2012 05:20

OpenEdge Release: 10.2B05

I'm working on a very simple .NET form which contained a single Infragistics UltraChart.

It's being launched from an existing ADM-based application, although I'm not sure if that is relevant.

I'm passing in some simple data strings, creating a temp-table, query and data source and my chart appears - everything works pretty-much as I would like it to.

But then I added another control - a standard combo-box (no code added, literally just added to the form) and got a run-time error:

Incompatible datatypes found during runtime conversion (5729)

I deleted the combo-box away and the error disappeared.

I thought perhaps I had somehow corrupted things as I've been playing around learning; so I created a new form; added a combo-box; and everything worked fine.

But then I added another standard control (a button this time) ...and the error came back.

Am I missing something glaringly obvious in my naievety (this is our first foray into GUI for .NET) or does this sound like a bug ?

Any pointers appreciated.

All Replies

Posted by Shelley Chase on 27-Mar-2012 10:08

Hi Gareth,

This is not expected behavior. Feel free to call tech support so they can help you figure out what is going on.



Posted by asthomas on 27-Mar-2012 10:11

Jeg er væk fra kontoret den 27. marts 2012, og checker ikke altid mail og telefon regelmæssigt. Jeg vil dog svare på din mail så snart som muligt.

Hvis du har behov for support, kontakt venligst, så vender vi tilbage så snart det er mnuligt.

Administrative henvendelser kan ske til :

I am not in the office 27th March 2012. I will not be checking my mail and phone on a regular basis, but will reply to your mail as soon as I can.

If you need support from appSolutions, please send your mails to

If you need Roundtable support, please send mails to :

Med venlig hilsen / Regards

Thomas Hansen

appSolutions a/s

Posted by ge1971 on 10-Apr-2012 10:58

Thought I'd just post a follow-up in case anyone else runs into the problem and stumbles onto this query.

I'm running a Visual Studio session for editing the .NET form and code; but simultaneously running an AppBuilder session where I have an ADM window which is instantiating the .NET form.  To test I run the ADM window from within the AppBuilder.

If I compile the .NET code and run the ADM window from within the AppBuilder I get the above error when the .NET window is instantiated.

If I completely close the AppBuilder session, restart it and then run my ADM window then the error goes away.

Sounds like a glitch to me, but at least I know what caused the problem now and can work around it.

This thread is closed