Checking syntax takes long because of assemblies

Posted by gdb390 on 19-Nov-2012 05:47


I have created a form called uiOrgani.  Nothing in it, just as generated by progress.

In a procedure editor (started with -assemblies start up parameter) , I want to check the below code :

using "ui.base.uiOrgani" from propath.

define variable o as ui.base.uiOrgani no-undo.

o = new ui.base.uiOrgani ( ).

wait-for System.Windows.Forms.Application:Run ( o ).

If I check syntax it takes approx. 1 minute before I get the syntax OK or error dialog.

If I do this again, immediately afterwards, the dialog is shown without delay.

I think this has something to do with the loading of the assemblies, but I don't have a clue.

If I run the code at the customer's site, It also takes that long !

Used progress version = 10.2B SP 04

Any ideas why this is so slow ?

kind regards


All Replies

Posted by Admin on 19-Nov-2012 05:58

using "ui.base.uiOrgani" from propath.

There's no need and no value in putting quotes around type names. But that's certainly unrelated to your issue.

If I check syntax it takes approx. 1 minute before I get the syntax OK or error dialog.


It has been reported here that DNS or network issues may have an impact when the .NET runtime tries to verify the certificates of the assemblies. Maybe this here helps:

Used progress version = 10.2B SP 04


SP7 is current, by the way.

Posted by Wouter Dupré on 19-Nov-2012 06:06

To add to Mike's comments:

* What does your propath look like?

* I've tried what you did on 11.1 and don't see the issue. The first "check syntax" is slightly slower than the next ones, but it's still sub-second and not even close to 1 minute.



Posted by Matt Baker on 19-Nov-2012 08:05

You can add -preloadCLR to your startup parameters.  This will make the AVM take longer to start but will mitigate some of the initial time needed to perform your first check syntax.  This won't fix any issues with the PROPATH being very long or having entries on a network drive.

Posted by gdb390 on 19-Nov-2012 09:10

Thank you all for the quick responses and especially Mike, because that was the trick !

There was no internet connection on that machine so we had to wait to the time out before continuing !

From 10.2B02 onwards, there seems to be a certificate control.

So Mike, thanks a lot, I had searched the knowledge base, but apparently with the wrong keywords !

That will be a bottle of whisky instead of a beer the next time we meet !



This thread is closed