Focus lost in embedded ABL window

Posted by MBeynon on 13-May-2013 03:25


I have an ABl window embedded in a .NET form via a window container. The problem is I can't seem to get focus in the first field of the ABL window once it is embedded.

What I mean by this is I can't get the 'blink' cursor to show in the first editor widget. I've tried using APPLY "ENTRY" TO myTextWidget as the very last step but it does not seem to work and the focus

seems to remain with the .NET form.

Does anyone else have any experience of this?



All Replies

Posted by Peter van Dam on 30-Jan-2014 08:41

This is a known bug that has finally been fixed in OE 11.3.2.

Posted by Matt Gilarde on 31-Jan-2014 09:42

As Peter said, this issue should be fixed in 11.3.2. If you find that it is still not working, please report the issue to Tech Support.

We have had reports that using SESSION:SET-WAIT-STATE can cause similar issues, so if you are using SET-WAIT-STATE while creating and displaying the embedded window try it without SET-WAIT-STATE.

This thread is closed