TDE keystore failure (on replicated environment)

Posted by Pieterm on 24-Feb-2020 21:31

We have an customer environment with 2 databases, both with replication enabled with single targets.
Two weeks ago we applied TDE on these databases, on top of the replication still enabled.
Everything worked fine, but when we did a restart of the source databases recently, one of the databases failed to start up with errors.

The knowledge base articles I found either states, 'find the correct keystore pair',
or "The exact cause is not known at this time." and workaround is to implement TDE by disable replication first before enabling TDE, and then enable replication and rebuild DR.
I have tried various options but are unable to access the database, as it does not recognize the database keystore.
The keystore file and even backup keystore files does not work, and the db is now encrypted and locked down.

Fortunately the replication environment was accessible and we recovered from there.
I made a O/S copy of the databases as no progress utilities could access the database.
Any suggestion on what else to try to access the database?

SHUT 15: (452) Login by root on /dev/pts/0.
SHUT 15: (542) Server shutdown started by root on /dev/pts/0.
BROKER 0: (15193) The normal shutdown of the database will continue for 10 Min 0 Sec if required.
BROKER 0: (2248) Begin normal shutdown
AIMGT 7: (2519) Disconnected.
APW 12: (2519) Disconnected.
WDOG 13: (2519) Disconnected.
AIW 14: (2520) Stopped.
BIW 6: (2520) Stopped.
BROKER 0: (2527) Disconnecting dead user 7.
BROKER 0: (15109) At Database close the number of live transactions is 0.
BROKER 0: (15743) Before Image Log Completion at Block 1101 Offset 5310.
BROKER 0: (10485) The Fathom Replication Server is shutting down.
BROKER 0: (-----) Sending signal 12 to user 5
RPLS 5: (18958) The Replication Server attempted shutdown of agent hcdr on host hc-dr. The agent will enter pretransition according to the specified agent-shutdown-action property.
RPLS 5: (10505) The Fathom Replication Server is ending.
RPLS 5: (453) Logout by root on /dev/pts/0.
BROKER 0: (10486) Shutdown of the Fathom Replication Server is complete.
BROKER 0: (453) Logout by root on /dev/pts/0.
BROKER : (16869) Removed shared memory with segment_id: 2093645827
BROKER : (334) Multi-user session end.
SHUT 15: (453) Logout by root on /dev/pts/0.

BROKER 0: (333) Multi-user session begin.
BROKER 0: (10545) Connections to this database will not be allowed until all Database Services started have completed their startup and initialization.
BROKER 0: (15321) Before Image Log Initialization at block 1101 offset 5310.
BROKER 0: (15014) dbecLoad: Internal security service error {3} (dksp) Key store load failed
BROKER 0: (15014) dbecLoad: Internal security service error {3} (keystore) invalid database binding {02021b53}
BROKER 0: (15082) SYSTEM ERROR: dbecLoad: Unable to load security policy -101
BROKER 0: (15396) Physical Redo 1: Failure to load encryption cache.
BROKER : (16869) Removed shared memory with segment_id: 2133032963
BROKER : (334) Multi-user session end.

All Replies

This thread is closed