Progress 12 conv1112 utility - issue with database access af

Posted by prowynne1 on 16-Sep-2019 09:41

Hi All

I have an issue using the conv1112 utility for a database on 11.4 to progress 12.

This is an enterprise DB with large files enabled, auditing turned on.

The conversion seems to work without error - but just trying to get into the database gives and error.
The list of active features in database contains features that are not reconized by this codebase (11811).

Any ideas - what the issue may be.



All Replies

Posted by Valeriy Bashkatov on 16-Sep-2019 10:19


It depends on your actions during the conversion.

Are you using the correct DLC and PATH for version 12?

Did you make the following commands after conv1112?

proutil <dbname> -C updateschema

proutil <dbname> -C updatevst



Posted by prowynne1 on 16-Sep-2019 10:27

Hi Valeriy

Basic process ; we have a standard 11.4 database - ent.db.

Truncated BI as 11.4.

As 12 - ran conv1112.

No issues detected in conversion.

Try to access - get the 11811 error.

Try the updateschema - which presume the conversion should have done anyway - gets same issue.

        The list of active features in database hr contains features that are not recognized by this codebase (11811)


Only special features of this database are Auditing - which I presume is in the enterprise DB for the 12 Enterprise licence.

It had largefiles on which I believe is now "standard" and is not an option in 12.



(conversion stat)

[rcust@ip-172-31-5-5 data]$ proutil hr -C conv1112

OpenEdge Release 12.0 as of Fri Feb 22 18:13:59 EST 2019

You must have your database backed up before running the conversion. (1024)

Have you done this (y/n) ?


VST Table Deletion has begun. Please stand by. (6876)

VST Table Deletion has completed successfully. (6885)

Conversion completed, database is now in Progress OpenEdge Release 12 format. (19121)


Posted by prowynne1 on 16-Sep-2019 10:31

Tried it with another database that is not audit enabled - so could be auditing is the issue.

Posted by George Potemkin on 16-Sep-2019 10:36

Dump a master block:

Check mb_fmaDBContent vs mb_fmaDBEnabled

Posted by Valeriy Bashkatov on 16-Sep-2019 10:49

Just tried with the sports2000 database for which Auditing and large files support is enabled. No problem. But I upgraded to 12.1 from 11.7.5

What will the following command show under 11.4 and under 12.0?

proutil <dbname> -C describe

Posted by Ruanne Cluer on 27-Sep-2019 07:45

Out of interest, did you run the conv1112 with an OE 12 Enterprise Database License or an OE 12 Advanced Enterprise RDBMS license installed?

This thread is closed