brms.properties

Posted by archana.gupta on 11-Mar-2016 07:29

Hi,

Please suggest how to set the path of properties override files (brms.properies) for corticon server.

Thanks,

Archana

All Replies

Posted by Jan Krishnamurthy on 11-Mar-2016 08:01

brms.properties needs to be created and placed in the CORTICON_WORK_DIR location for Corticon Server.

Posted by gsaintma on 11-Mar-2016 08:48
I found it useful too!  I wondered about that when I was tweaking CcConfig.jar for .NET server log settings. Seems obvious enough…
Thanks.
 
Posted by Jan Krishnamurthy on 11-Mar-2016 09:18

For .NET you are free to use the brms.properties, but it is easy to edit the other  .properties file available in C:\inetpub\wwwroot\axis\conf and you don't have to tweak the CcConfig.jar

Posted by archana.gupta on 15-Mar-2016 02:50

As per the documentation, the brms.properties needs to be placed in the corticon_home directory, which in my case in application server home directory (Corticon Work: /usr/local/apache-tomcat-7.0.62/bin) . Please suggest if there is any way to change this default home directory.

Thanks,

Archana

Posted by mcicel on 15-Mar-2016 07:04

See documentation.progress.com/.../index.html

Corticon is using CORTICON_HOME system variable, which is set in \bin\corticon_env.bat. You can modify it there. You can also set it globally or pass to the server using -D option.

Marian

Posted by archana.gupta on 15-Mar-2016 07:48

Thank you for your response, however, the corticon server is created by deploying axis.war file on the tomcat on Unix machine. On this Unix machine, there is no bin\corticon_env.bat file.

Please give more detail about how to use -D option.

Posted by mcicel on 15-Mar-2016 08:14

On Unix you can set CORTICON_HOME by running:

export CORTICON_HOME=<path>

on the command line before you start the server.

Posted by Prashant Thumma on 15-Mar-2016 09:02
Hi Archana,
The easiest way to set the CORTICON_HOME and CORTICON_WORK_DIR is to pass them as a JVM environment argument.  You can do that by setting the CATALINA_OPTS environment variable:
 
Unix:
export CATALINA_OPTS="$CATALINA_OPTS -DCORTICON_HOME=<CORTICON_INSTALLATION_DIR> -DCORTICON_WORK_DIR=<YOUR_CORTICON_WORK_DIR>”
 
Windows:
set CATALINA_OPTS="%CATALINA_OPTS% -DCORTICON_HOME=<CORTICON_INSTALLATION_DIR> -DCORTICON_WORK_DIR=<YOUR_CORTICON_WORK_DIR>”
 
-Prashant
 
Posted by archana.gupta on 18-Mar-2016 00:38

Thanks,

That resolved my problem.

This thread is closed