WCF webservice Access through Webservice Managed Adapter

Posted by rpanda on 27-Jul-2011 02:18

When I am configuring ASMX(.Net Webservices) in Managed Webservice Adapter it’s behaving normal. But,  I am facing configuration issue while using WCF(.net Advanced Webservices) in Managed Webservice Adapter. Our Adapter is not recognizing the service link(We have received WCF service link from our Client).
I am providing the difference between two links:
ASMX link: http://<IPAddress>/ITSWebService/ITSService.asmx?WSDL – Configurable in Managed Webservice Adapter
WCF link  : http://<IPAddress>/ITSWebService/ITSService.svc?WSDL – Not Configurable in Managed Webservice Adapter L

Is anybody using WCF services? 

All Replies

Posted by vivekraj on 27-Jul-2011 04:23

Hi Rajat,

there are different kind of binding in WCF link

BasicHttpBinding--supports by savvion web service adpaters

The rest of the binding are not WS-* compliant and need extra information like the authetication so it would not work as Webservice Managed Adapter




Posted by DannyGeerts on 27-Jul-2011 04:26

Beste mailer,

Ik ben van maandag 25 juli t/m vrijdag 12 augustus afwezig. Heeft u

een dringende vraag? Neem dan contact op met het algemene nummer

(0527) 61 47 67.


Met vriendelijke groet,

Danny Geerts

Consultant BPM

Posted by rpanda on 27-Jul-2011 06:17

Hey Guys!

I found the solution based on Vivek Raj's information. Customer was using WSHttpBinding for preparing the webservice in the same WCF approach. Now they tried it with BasicHttpBinding which is like a piece of cake for our Managed Webservice adapter.

It WORKED!!! Thank you Vivek for your valuable information!!

Thanks & Regards,

Rajat Panda

This thread is closed